Missing UTP Trade Data from 12/04/2025 (4:00 PM ET)

Incident Report for Massive Inc

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 08:19 EST

Identified

We have identified missing trades for UTP securities affecting the 4:00 PM ET market close on December 4, 2025.

The team is currently backfilling this data. Full restoration is scheduled for completion at midnight (12:00 AM ET) on 12/06/2025. We apologize for the inconvenience.
Posted Dec 05, 2025 - 13:30 EST
This incident affected: Stocks (Market Data REST Endpoints, Market Data WebSocket Channels, Market Data Flat Files).